View Issue Details

IDProjectCategoryView StatusLast Update
0000256Siril[All Projects] Sirilpublic2018-09-08 22:06
Reporterlock42Assigned Tolock42 
PriorityhighSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
PlatformGNU/Linux 64bitsOSDebianOS VersionTesting
Product Version0.9.9 
Target Version0.9.10Fixed in Version0.9.10 
Summary0000256: Make RGB Flat normalization for Johnson photometry
DescriptionFor now, flats are not normalized. That could be a problem for Johnson Photometry that need to preserve B/G and R/G ratios during flat division.
Siril is for now only usable in TG photometry (i.e, with non-corrected green channel).
So each R and B pixels of the flat must be multiplied by a factor in order to normalize the flat.
TagsNo tags attached.

Activities

lock42

2018-06-06 16:02

administrator   ~0000551

Interresting discusison with specialist:

Regarding photometry: it would be better not to disturb initial channel ratio during calibration. If we are working solely with green channel it is not a problem at all. However, there are approaches where channel ratio is important:
1) V-band synthetic filter approach developed by Roger Pieri requires knowing of "real" R/G/B ratio for a certain sensor/telescope combination.
2) Traditional transformation of standardized magnitudes (to compensate systematic errors caused by non-standard nature of Bayer's filters) requires knowing of B-V difference between target and comparison stars. In its standard implementation it does not require knowing of absolute ratio of G and B channels, however, if properly calibrated, we can derive B-V index for a star from its observed (b-v) value for a given sensor: we can determine a coefficients Tbv and Tz for a given sensor [B-V = Tz + Tbv * (b-v)] using standard star fields and consider Tz not as arbitrary zero level but one of sensor's characteristic. So we could determine actual B-V for our target star (variable) and use it in conjunction with catalog B-V values of comparison stars. This could be possible only if we can keep channel-to-channel ratio intact. IRIS has separate set of menu commands (it seems that those commands are available from GUI menu only) for DSLR images and it takes into account such nuances (it makes flat "grey" while dividing and take into account Bayer matrix when fixes defect (hot) pixels).

lock42

2018-09-06 11:17

administrator   ~0000599

Fix committed to Siril (2461).

Related Changesets

Siril: 0.9 r2461

2018-09-06 11:17:18

lock42

Details
Fix 0000256: A new command "grey_flat" is now available and it is possible to equalize flat cfa during preprocessing.
Fix 0000270: A new command SETFINDSTAR allow the user to change sigma and roundness for findstar and registration
Scripts have been updated with the new option of 0000256 -equalize_cfa
Affected Issues
0000256, 0000270
mod - /branches/0.9/3rdparty/scripts/en/DSLR_Preprocessing_Drizzle.ssf
mod - /branches/0.9/3rdparty/scripts/en/DSLR_Preprocessing_NoDark.ssf
mod - /branches/0.9/3rdparty/scripts/en/DSLR_preprocessing_Cosmetic.ssf
mod - /branches/0.9/3rdparty/scripts/en/DSLR_preprocessing_Drizzle_Cosmetic.ssf
mod - /branches/0.9/3rdparty/scripts/fr/Pre-traitement_APN.ssf
mod - /branches/0.9/3rdparty/scripts/fr/Pre-traitement_APN_AvecCorrectionCosmetique.ssf
mod - /branches/0.9/3rdparty/scripts/fr/Pre-traitement_APN_AvecDrizzle.ssf
mod - /branches/0.9/3rdparty/scripts/fr/Pre-traitement_APN_AvecDrizzle_AvecCorrectionCosmetique.ssf
mod - /branches/0.9/3rdparty/scripts/fr/Pre-traitement_APN_SansDark.ssf
mod - /branches/0.9/po/el.po
mod - /branches/0.9/po/es_ES.po
mod - /branches/0.9/po/fr.po
mod - /branches/0.9/po/it_IT.po
mod - /branches/0.9/po/nl_BE.po
mod - /branches/0.9/po/zh_CN.po
mod - /branches/0.9/scripts/DSLR_preprocessing.ssf
mod - /branches/0.9/src/algos/colors.c
mod - /branches/0.9/src/algos/colors.h
mod - /branches/0.9/src/algos/demosaicing.c
mod - /branches/0.9/src/algos/star_finder.c
mod - /branches/0.9/src/algos/star_finder.h
mod - /branches/0.9/src/algos/statistics.c
mod - /branches/0.9/src/algos/statistics.h
mod - /branches/0.9/src/core/command.c
mod - /branches/0.9/src/core/command.h
mod - /branches/0.9/src/core/command_def.h
mod - /branches/0.9/src/core/initfile.c
mod - /branches/0.9/src/core/proto.h
mod - /branches/0.9/src/core/siril.c
mod - /branches/0.9/src/core/siril.h
mod - /branches/0.9/src/core/utils.c
mod - /branches/0.9/src/gui/callbacks.c
mod - /branches/0.9/src/gui/siril3.glade
mod - /branches/0.9/src/io/conversion.c
mod - /branches/0.9/src/io/conversion.h

Siril: 0.9 r2462

2018-09-06 15:51:15

lock42

Details
Probably fixes a bug in 0000256, but need to be fixed with different Bayer pattern
Affected Issues
0000256
mod - /branches/0.9/ChangeLog
mod - /branches/0.9/NEWS
mod - /branches/0.9/src/algos/colors.c
mod - /branches/0.9/src/algos/demosaicing.c

Siril: 0.9 r2463

2018-09-07 10:23:55

lock42

Details
Make flat equalizer much easier (0000256). No known Bayer patterns needed anymore because the algorithm is now able to detect it by analyzing pixels in the flat image. More robust. Affected Issues
0000256
mod - /branches/0.9/src/algos/colors.c
mod - /branches/0.9/src/algos/colors.h
mod - /branches/0.9/src/core/siril.c
mod - /branches/0.9/src/io/conversion.c
mod - /branches/0.9/src/io/conversion.h
mod - /branches/0.9/src/io/image_formats_libraries.c

Siril: 0.9 r2468

2018-09-08 22:06:05

lock42

Details
Improving issue 0000256 by computing statistics in the center of the flat Affected Issues
0000256
mod - /branches/0.9/po/el.po
mod - /branches/0.9/po/es_ES.po
mod - /branches/0.9/po/fr.po
mod - /branches/0.9/po/it_IT.po
mod - /branches/0.9/po/nl_BE.po
mod - /branches/0.9/po/zh_CN.po
mod - /branches/0.9/src/algos/colors.c
mod - /branches/0.9/src/algos/statistics.c
mod - /branches/0.9/src/algos/statistics.h
mod - /branches/0.9/src/core/command.c
mod - /branches/0.9/src/core/siril.c

Issue History

Date Modified Username Field Change
2018-06-06 10:02 lock42 New Issue
2018-06-06 10:02 lock42 Status new => assigned
2018-06-06 10:02 lock42 Assigned To => lock42
2018-06-06 16:02 lock42 Note Added: 0000551
2018-09-06 11:17 lock42 Changeset attached => Siril 0.9 r2461
2018-09-06 11:17 lock42 Note Added: 0000599
2018-09-06 11:17 lock42 Status assigned => resolved
2018-09-06 11:17 lock42 Resolution open => fixed
2018-09-06 11:37 lock42 Fixed in Version => 0.9.10
2018-09-07 10:44 lock42 Changeset attached => Siril 0.9 r2463
2018-09-07 10:44 lock42 Changeset attached => Siril 0.9 r2462
2018-09-08 22:06 lock42 Changeset attached => Siril 0.9 r2468