View Issue Details

IDProjectCategoryView StatusLast Update
0000244Siril[All Projects] Sirilpublic2018-05-22 21:15
Reporterlock42Assigned Tovinvin 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformGNU/Linux 64bitsOSDebianOS VersionTesting
Product Version0.9.8 
Target Version0.9.9Fixed in Version0.9.9 
Summary0000244: Execute script file in another thread
DescriptionFor now, executing script file can not be done for functions that have ben run in another thread.
We must write a wait function and run the script in another thread.
TagsNo tags attached.

Relationships

related to 0000009 confirmedlock42 Command line improvements 

Activities

vinvin

2018-05-22 02:33

administrator   ~0000548

When the script is interrupted, the thread status is not propagated and fails when another script is launched.

vinvin

2018-05-22 21:15

administrator   ~0000549

Fix committed to Siril (2354).

Related Changesets

Siril: 0.9 r2196

2018-04-08 15:10:13

vinvin

Details
Trying to implement issue 0000244: scripting from file with waits.
Affected Issues
0000244
mod - /branches/0.9/src/core/command.c
mod - /branches/0.9/src/core/processing.c
mod - /branches/0.9/src/core/processing.h
mod - /branches/0.9/src/gui/callbacks.c
mod - /branches/0.9/src/gui/callbacks.h
mod - /branches/0.9/src/gui/progress_and_log.c
mod - /branches/0.9/src/gui/progress_and_log.h

Siril: 0.9 r2204

2018-04-12 01:05:58

vinvin

Details
Changing idle function registration for script command sequencing fix (issue 0000244).
Adding a global flag to deactivate them, com.headless.
The load command will not work in scripts because it calls many graphical things, but stack and register and other image processing things should be fine.
Affected Issues
0000244
mod - /branches/0.9/src/algos/colors.c
mod - /branches/0.9/src/algos/cosmetic_correction.c
mod - /branches/0.9/src/algos/cosmetic_correction.h
mod - /branches/0.9/src/algos/fft.c
mod - /branches/0.9/src/core/command.c
mod - /branches/0.9/src/core/processing.c
mod - /branches/0.9/src/core/processing.h
mod - /branches/0.9/src/core/siril.c
mod - /branches/0.9/src/core/siril.h
mod - /branches/0.9/src/core/siril_update.c
mod - /branches/0.9/src/gui/callbacks.c
mod - /branches/0.9/src/gui/save_dialog.c
mod - /branches/0.9/src/io/conversion.c
mod - /branches/0.9/src/io/sequence.c
mod - /branches/0.9/src/io/sequence_export.c
mod - /branches/0.9/src/io/single_image.c
mod - /branches/0.9/src/registration/registration.c
mod - /branches/0.9/src/registration/registration.h
mod - /branches/0.9/src/stacking/stacking.c

Siril: 0.9 r2354

2018-05-22 21:15:31

vinvin

Details
Fixes 0000244, script abortion and restart.
Affected Issues
0000244
mod - /branches/0.9/src/core/command.c
mod - /branches/0.9/src/core/processing.c
mod - /branches/0.9/src/core/siril.h
mod - /branches/0.9/src/io/sequence.c

Issue History

Date Modified Username Field Change
2018-03-18 09:32 lock42 New Issue
2018-03-18 20:37 vinvin Assigned To => vinvin
2018-03-18 20:37 vinvin Status new => assigned
2018-04-08 15:10 vinvin Changeset attached => Siril 0.9 r2196
2018-04-12 01:06 vinvin Changeset attached => Siril 0.9 r2204
2018-04-13 01:14 vinvin Status assigned => resolved
2018-04-13 01:14 vinvin Resolution open => fixed
2018-04-13 01:14 vinvin Fixed in Version => 0.9.9
2018-04-13 01:14 vinvin Relationship added related to 0000009
2018-05-22 02:31 vinvin Status resolved => assigned
2018-05-22 02:33 vinvin Note Added: 0000548
2018-05-22 21:15 vinvin Changeset attached => Siril 0.9 r2354
2018-05-22 21:15 vinvin Note Added: 0000549
2018-05-22 21:15 vinvin Status assigned => resolved