View Issue Details

IDProjectCategoryView StatusLast Update
0000237Siril[All Projects] Sirilpublic2018-03-07 13:24
ReporterStrongheartAssigned Tovinvin 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSLinux Mint 18.3 Sylvia OS Version
Product Version0.9.8 
Target Version0.9.9Fixed in Version0.9.9 
Summary0000237: Incorrect One Star registration and stacking for 8-bit FITS
DescriptionOne Star Registration on attached image sequence produces wrong results with Version 0.9.8-002 ; see also attached .seq file.
I processed the same images with version 0.9.1, and the results were Ok.

Steps To ReproduceLoad the sequence from the attached archive file and perform a One Star registration on the brightest star in the image.
Tagsregistration

Relationships

related to 0000242 resolvedlock42 Autostretch does not work on 8bit images anymore 

Activities

Strongheart

2018-02-17 01:10

reporter  

TestSequence.7z (1,675,116 bytes)

vinvin

2018-02-17 01:27

administrator   ~0000474

Hi, thanks for the report and the file, sorry for the bug.
It may take us a while to download it and test it, in the mean time, when you say it produces wrong results, how do you see it, with stacking? If so, which type of stacking?

vinvin

2018-02-17 11:15

administrator   ~0000475

Ok I thought it was 1.6GB and not 1.6kB. I confirm there is a problem, I don't understand why for now because it works on some other sequences.

vinvin

2018-02-17 12:39

administrator   ~0000476

8-bit FITS do not work for this kind of operation. I will fix it, until then you can convert them to 16-bit or SER.
Sorry

Strongheart

2018-02-18 23:26

reporter   ~0000477

Thank you very much for the prompt response. The SER files worked fine with me.

vinvin

2018-02-21 01:52

administrator   ~0000478

Fix committed to Siril (2125).

vinvin

2018-02-21 01:54

administrator   ~0000479

The fix will be available in the next release. Thanks for noticing the error.
See this new page for documentation of supported FITS formats too: https://free-astro.org/index.php?title=Siril:supported_FITS

Related Changesets

Siril: 0.9 r2125

2018-02-21 01:52:52

vinvin

Details
Rewrite of FITS reading, fixes 0000237.
Now all supported FITS formats are converted with the same function for entire, partial, and opened partial reads.
Conversions have been simplified for homogeneity over the sequence, this is documented on wiki "Siril:supported FITS".
Affected Issues
0000237
mod - /branches/0.9/src/core/proto.h
mod - /branches/0.9/src/core/siril.h
mod - /branches/0.9/src/io/image_format_fits.c
mod - /branches/0.9/src/io/sequence.c
mod - /branches/0.9/src/io/sequence_export.c
mod - /branches/0.9/src/registration/registration.c
mod - /branches/0.9/src/stacking/stacking.c

Issue History

Date Modified Username Field Change
2018-02-17 01:10 Strongheart New Issue
2018-02-17 01:10 Strongheart File Added: TestSequence.7z
2018-02-17 01:10 Strongheart Tag Attached: registration
2018-02-17 01:27 vinvin Note Added: 0000474
2018-02-17 01:28 vinvin Priority normal => high
2018-02-17 01:28 vinvin Status new => acknowledged
2018-02-17 01:28 vinvin Target Version => 0.9.9
2018-02-17 11:15 vinvin Assigned To => vinvin
2018-02-17 11:15 vinvin Status acknowledged => assigned
2018-02-17 11:15 vinvin Note Added: 0000475
2018-02-17 12:39 vinvin Note Added: 0000476
2018-02-17 12:40 vinvin Summary Incorrect One Star Registration => Incorrect One Star Registration for 8-bit FITS
2018-02-17 23:30 vinvin Summary Incorrect One Star Registration for 8-bit FITS => Incorrect One Star registration and stacking for 8-bit FITS
2018-02-18 23:26 Strongheart Note Added: 0000477
2018-02-21 01:52 vinvin Changeset attached => Siril 0.9 r2125
2018-02-21 01:52 vinvin Note Added: 0000478
2018-02-21 01:52 vinvin Status assigned => resolved
2018-02-21 01:52 vinvin Resolution open => fixed
2018-02-21 01:54 vinvin Fixed in Version => 0.9.9
2018-02-21 01:54 vinvin Note Added: 0000479
2018-03-07 13:24 lock42 Relationship added related to 0000242