View Issue Details

IDProjectCategoryView StatusLast Update
0000225Siril[All Projects] Sirilpublic2018-08-26 14:11
ReportervinvinAssigned To 
PriorityhighSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version 
Target Version0.9.8Fixed in Version0.9.8 
Summary0000225: Exporting the up-scaled sequence does not use the correct selection filter
DescriptionI've seen that all images of a sequence are up-scaled when only a few are selected for stacking. I don't know why of if it happens all the time.
TagsNo tags attached.

Activities

vinvin

2018-01-07 02:22

administrator   ~0000453

Last edited: 2018-01-07 02:28

View 2 revisions

Found a bug with the current fix, apparently stackargs->image_indices can be not up-to-date in some cases, which leads to a crash because data is not real data (stacking.c:2192).
Ok it was because I had an old up-scaled sequence from an older version (or from a crash) with not the same number of images before starting the stacking.

Related Changesets

Siril: 0.9 r1974

2018-01-05 16:32:17

lock42

Details
Fixes bug in Drizzle (0000215) Affected Issues
0000225
mod - /branches/0.9/src/stacking/stacking.c

Issue History

Date Modified Username Field Change
2018-01-04 09:50 vinvin New Issue
2018-01-04 22:52 vinvin Assigned To => vinvin
2018-01-04 22:52 vinvin Status new => assigned
2018-01-04 23:10 vinvin Reproducibility have not tried => unable to reproduce
2018-01-04 23:10 vinvin Status assigned => resolved
2018-01-04 23:10 vinvin Resolution open => unable to reproduce
2018-01-04 23:10 vinvin Status resolved => closed
2018-01-05 09:41 vinvin Assigned To vinvin =>
2018-01-05 09:41 vinvin Status closed => confirmed
2018-01-05 09:42 vinvin Priority normal => high
2018-01-05 09:42 vinvin Severity minor => major
2018-01-05 09:42 vinvin Reproducibility unable to reproduce => random
2018-01-05 09:42 vinvin Resolution unable to reproduce => open
2018-01-05 21:50 lock42 Changeset attached => Siril 0.9 r1974
2018-01-07 02:22 vinvin Note Added: 0000453
2018-01-07 02:28 vinvin Note Edited: 0000453 View Revisions
2018-01-15 22:47 vinvin Status confirmed => resolved
2018-01-15 22:47 vinvin Resolution open => fixed
2018-01-15 22:47 vinvin Fixed in Version => 0.9.8
2018-08-26 14:09 lock42 Changeset attached => Siril 0.9 r2450
2018-08-26 14:11 lock42 Changeset removed Siril 0.9 r2450 =>